你的位置:首页 > Java教程

[Java教程]总结eclipse中安装maven插件


   当自己越来越多的接触到开源项目时,发现大多数的开源项目都是用maven来够建的。并且在开发应用时,也越来越意识到maven的确会解决很多问题,如果你要了解maven,可以参考:Maven入门指南(一)和 Maven入门指南(二)。所以自己也学着使用maven。以下均参考的互联网上的内容,有的做了一些小的修改,并注明了出处。

 

第一部分:原文链接

maven3 安装:

    安装 Maven 之前要求先确定你的 JDK 已经安装配置完成。Maven是 Apache 下的一个项目,目前最新版本是 3.0.4,我用的也是这个。

    首先去官网下载 Maven:http://www.apache.org/dyn/closer.cgi/maven/binaries/apache-maven-3.0.4-bin.tar.gz

    下载完成之后将其解压,我将解压后的文件夹重命名成 maven,并将它放在 D:\Server 目录下,即 maven 最终的路径是:D:\Server\maven


配置 maven 环境变量:

    系统变量:MAVEN_HOME = D:\Server\maven

    用户变量:path = %MAVEN_HOME%\bin

    相信大家都有配过环境变量的,详细步骤就不说了,对着把属性名和属性值配上的OK了。

    打开 cmd,在里面敲:mvn -version

 


    如果能打印如上信息,说明到此 Maven3 已经在你的电脑上安装完成。
    mvn 是 mavn 的一个指令,mvn -version 是查看版本信息,我的操作系统是 32位的 WIN7,安装的 maven 是 3.0.4

    如果能打印如上信息,说明到此 Maven3 已经在你的电脑上安装完成。


修改 maven 仓库存放位置:

    找到 maven 下的 conf 下的 settings.



    maven 的仓库默认是放在本地用户的临时文件夹下面的 .m2 文件夹下的 repository 下,我的是在 C:\Users\admcnm\.m2\repository 目录下,

    现在我们来修改将它指定到我们自己的路径下,我现在要将仓库指定到 D:\Repositories\Maven 目录下,只需要将上面注销的本地仓库打开,

    然后把相应的路径值写到里面去就行了:

OK,先来体会一下 maven,在 cmd 中敲并回车执行:mvn help:system

    这时候 maven 就会从远程仓库开始下载一大堆的东西,没事,让它下载着,迟早都要下载的,接下来是在 eclipse 中安装 maven 插件。

然后在线安装eclipse插件::Help  -->  Install New Software,然后输入 HTTP 地址来安装(http://download.eclipse.org

),可以在此链接中找相对应的版本。

最后:

检查 eclipse 的 maven 插件是否安装成功:Window  -->  Preferences




配置 maven:
    1. 点击 Add 按钮,选到你本机安装 maven 的路径值




    2. 点击 Browse 按钮,选到你 maven 的 setting.

二、在eclipse安装maven插件时,可能会遇到的错误:原文链接1 ,原文链接2

1.安装m2eclipse的时候,遇见这种错误如何解决?错误请见详细信息。

问题:Cannot complete the install because one or more required items could not be found.

Software being installed: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (or
g.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)

Missing requirement: Maven Project Model Edit Bundle 0.12.1.20110112-1712 (org.maven.id
e.eclipse.maven_model_edit 0.12.1.20110112-1712) requires 'bundle org.eclipse.emf.ecore 0.
0.0' but it could not be found

Cannot satisfy dependency:

From: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclip
se.feature.feature.group 0.12.1.20110112-1712)

To: org.maven.ide.eclipse.maven_model_edit [0.12.1.20110112-1712] 他说有个文件找不到
。但是到Maven的m2e的链接中,相关文件又是存在的。试了很多次了。都有这个问题。

解决:先连接Helios Update site (Helios - http://download.eclipse.org/releases/helios),安装
插件Graphical Editing Framework Zest Visualization Toolkit SDK。然后再安装 M2Eclipse plug-ins 。
2:如果装的插件版本太高会报
Cannot complete the install because one or more required items could not be
 found.
  Software being installed: m2e - Maven Integration for Eclipse (includes I
 
ncubating components) 1.5.0.20140606-0033 (org.eclipse.m2e.feature.feature.
 
group 1.5.0.20140606-0033)
  Missing requirement: Maven Integration for Eclipse 1.5.0.20140606-0033 (o
 
rg.eclipse.m2e.core 1.5.0.20140606-0033) requires 'bundle com.google.guava
 
 [14.0.1,16.0.0)' but it could not be found
 
  Cannot satisfy dependency:
 
    From: Maven Integration for Eclipse 1.5.0.20140606-0033 (org.eclipse.m2
 
e.core.ui 1.5.0.20140606-0033)
 
    To: bundle org.eclipse.m2e.core [1.5.0,1.6.0)
 
  Cannot satisfy dependency:
 
    From: m2e - Maven Integration for Eclipse (includes Incubating componen
 
ts) 1.5.0.20140606-0033 (org.eclipse.m2e.feature.feature.group 1.5.0.201406
 
06-0033)
 
答案:这种情况换一个低版本的安装,如
 
http://download.eclipse.org/technology/m2e/milestones/1.4
 
转自http://blog.csdn.net/wode_dream/article/details/38052639