你的位置:首页 > 操作系统

[操作系统]mac系统 下 npm 安装 bower报错


在mac终端运行 sudo npm install -g bower

(安装之前你要确定你已经成功安装了node 和 git)

然后会报错 like this:

npm ERR! Darwin 15.4.0npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "install" "-g" "bower"npm ERR! node v5.2.0npm ERR! npm v3.3.12npm ERR! path /Users/path-to-directory/node_modules/npm/node_modules/rimraf/bin.js
...
npm ERR! shasum check failed for /tmp/npm-12464-50e9876a/registry.npmjs.org/bower/-/bower-1.8.0.tgz
...

解决办法:
先在终端运行:
xcodebuild -license

再运行:sudo npm install -g bower