你的位置:首页 > 操作系统

[操作系统]vim配置


1.背景说明:

  vim编辑器是linux一款非常流行功能强大的文本编辑。配置好vim可大大提高代码的开发效率

2.配置方案:

  我在github搜索了别人是如何进行vim配置的,在这里你可以选择一款适合你的配置方案,这里我选择Star比较多的配置方案:vimrc

  

3.如何安装:

  参考上述链接,安装说明很详尽(由于网络原因,可能下载安装比较慢,耐心等待即可)

3.遇到问题:

  我当前使用系统:Linux version 4.4.0-21-generic (buildd@lgw01-21) (gcc version 5.3.1 20160413 (Ubuntu 5.3.1-14ubuntu2) ) #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016

  按照作者说明文档进行安装完成后,在使用过程中遇到可能由于系统或者软件版本的原因某些插件并不能正常运行

  例如我在使用过程中就遇到了如下的问题:

  vim 打开一个filename.py的python文件,vim会提示如下图的错误:

  

  我们根据错误提示,我们打开错误提示所在的文件:

  

  我们可以知道pyflakes.vim这个插件需要vim对python的支持。针对这个提示,我们来检查当前的vim对python的支持情况

  执行该指令:grep --version | grep python

  

  如图我们可以得知,-python 和 +python3 说明当前vim支持对python3的支持,对python2并不支持,但是pyflakes.vim并没有支持python3

  那么这时候就应该安装python2,从而让vim对python2的支持。

4.安装软件

  我们可以这里获取相应版本的软件:vim-nox-py2

  这里以nox为例:sudo apt-get install vim-nox-py2

  等待安装完成输出一下指令进行vim对python与python3的切换:sudo update-alternatives --config vim

  如下图:

  

  编号0对应的是vim默认支持的python3 我们这里选择我们刚刚安装的vim-nox-py2也就是编号3

  这个时候我们再次输入:grep --version | grep python查看vim对python支持的版本是否切换过来了

  

  至此我们完成了vim对python版本支持的切换.

  pyflakes.vim该插件也可进行正常使用