你的位置:首页 > ASP.net教程

[ASP.net教程].NetCore~框架版本号不同引起dotnet不能run它


对于.netCore来说,今年已经推出了正式版,这要求使用vs2015的开发者需要升级到beta3版,而如果使用老版VS开始的.netCore应用程序,它的架构版本将为是测试版"version": "1.0.0-rc2-3002702",而对于这个问题,将会给我们部署带来麻烦,在一个新的centos环境下,你安装了最新版的.netCore之后,你之前开发的老版程序无法运行,出现一些警告,这让我们无从下手,我确实不想升级我的VS,也不能从新部署老应用,应该如何解决这个问题?

解决方法简单至极

1 打开你的包管理文件文件,project.json

2 找到dependencies>Microsoft.NETCore.App>version

3 将这个version修改成1.0.0即可,现在我们的程序就可以运行了

有时,我们解决一个问题,就是这样简单!