你的位置:首页 > 操作系统

[操作系统]Failed to apply plugin [id com.android.application] 和 Could not find com.android.tools.build:gradle:2.XX的最正确的解决方法


发现android studio是真的可爱啊,上一秒还没问题可以build运行,下一秒就出错。。。好,你任性,你牛逼。。

说下今天又遇到的两个问题:Failed to apply plugin [id 'com.android.application']和Could not find com.android.tools.build:gradle:2.XX.

1.Failed to apply plugin [id 'com.android.application']. Could not create plugin of type 'AppPlugin'.

Error:(1, 1) A problem occurred evaluating project ':eventactiondispatcher'.> Failed to apply plugin [id 'com.android.application']> Could not create plugin of type 'AppPlugin'. If using the gradle wrapper, try editing the distributionUrl in D:\as_workspace\RecyclerView\gradle\wrapper\gradle-wrapper.properties to gradle-2.14.1-all.zip

刚开始遇到我是有点蒙逼的,真是佩服google,每次都能让我遇到不一样的问题。吐槽归吐槽,问题就得解决。

就按照提示编辑项目下的这个文件:gradle\wrapper\gradle-wrapper.properties。

#Mon Dec 28 10:00:20 PST 2015distributionBase=GRADLE_USER_HOMEdistributionPath=wrapper/distszipStoreBase=GRADLE_USER_HOMEzipStorePath=wrapper/distsdistributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip

最后一行改成最新的。。这次我是在线更新的,还担心会不会被墙,还好,一会就下完了。。如果你在这里下载很慢的话,推荐你离线更新,至于怎么离线更新,参考我这篇博客:教新手一步步解决:Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE environment variable to和更新gradle问题

就在我以为把gradle更新之后就没问题啦,谁知道又出来一个更牛逼的:Error:Could not find com.android.tools.build:gradle:2.14.1.

2.Error:Could not find com.android.tools.build:gradle:2.14.1.

你让我更新到2.14.1.然后你又说找不到!!fuck!!

rror:Could not find com.android.tools.build:gradle:2.14.1.Searched in the following locations:  file:/D:/Tools/android_studio2.1stable/gradle/m2repository/com/android/tools/build/gradle/2.14.1/gradle-2.14.1.pom  file:/D:/Tools/android_studio2.1stable/gradle/m2repository/com/android/tools/build/gradle/2.14.1/gradle-2.14.1.jarhttps://jcenter.bintray.com/com/android/tools/build/gradle/2.14.1/gradle-2.14.1.pomhttps://jcenter.bintray.com/com/android/tools/build/gradle/2.14.1/gradle-2.14.1.jarRequired by:  :RecyclerView:unspecified

  问题中只是说找不到!!也没什么提示。百度了下,也在stackoverflow找了下发现都是让你把gradle版本往低了改!这个版本不合适,改成低的确实可以解决问题,向下兼容吗。但是有新的我为什么要改成低的呢,这肯定不能解决根本问题!于是在没有任何参照的情况下,我试了试,很好一次就成功啦。果然跟我想的一样,这种问题嘛,只要把插件什么的都改成最新的,一般就解决问题。

你只要一步把Android Plugin Version改为最新的:2.2.0-beta3(这是目前最新的)。直接在Project Structru->Project->Android Plugin Version 中改了就好!

查看最新的Android Plugin Version:https://jcenter.bintray.com/com/android/tools/build/gradle/

查看最新的Gradle:Gradle Distributions。

 这是我配好之后的配置: