你的位置:首页 > Java教程

[Java教程]javascript之IE版本检测


近年来随着操作系统的升级以及各种新技术的开发普及,抛弃低版本IE已经是大势所趋,这对于前端人员来时是个好消息,可以不用花费太多的时间来做低版本的兼容,很多站点采用给予低版本IE以提示的方式(恩,很友好很人道)给游客,一般是在header上给一个提示,脚本检测如下:

function getIEVersion(){    var rv = -1; // Return value assumes failure.    if(navigator.appName == 'Microsoft Internet Explorer') {        var ua = navigator.userAgent;        var re = new RegExp("MSIE ([0-9]{1,}[\.0-9]{0,})");if(re.exec(ua) != null)    rv = parseFloat(RegExp.$1);}return rv;}function checkVersion() {    var msg = "You're not using Internet Explorer.";    var ver = getIEVersion();    if(ver > -1) {        alert(ver);        if(ver >= 9.0)//这里写明要检测的版本            msg = "You're using a recent copy of Internet Explorer."        else            msg = "You should upgrade your copy of Internet Explorer.";    }    alert(msg);} 

这里的重点是使用了jsBOM的navigator对象,得到浏览器的版本信息,然后过滤出其中的ie信息(如果有),之后就可以根据结果来对web进行一定的操作了;在浏览器检测方面同样可以检索出其他浏览器的信息,按项目根据需要进行调整;