你的位置:首页 > Java教程

[Java教程]eclipse报错:Failed to load the JNI shared library


Eclipse运行时提示“Failed to load the JNI shared library /Java/jre6/bin/client/jvm.dll”的一个解决方案

因为 Eclipse 是64位的,所以也必须要需要 64位的jdk1.7 。 之前安装的是jdk1.6, 需要重新下载 jdk1.7 64位版本安装,并配置好环境变量。

但是运行时还是报上面的错误,需要修改eclipse.ini ,在下面的位置加上:

-startup
plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.300.v20150602-1417
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
C:/Program Files/Java/jdk1.7.0_79/bin/javaw.exe
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.7
-Xms256m
-Xmx1024m