你的位置:首页 > Java教程

[Java教程]出现异常:Unsupported major.minor version


今天在使用springboot的最新版本的时候出现了这个问题 ,抛出来的异常是:UnsupportedClassVersionError  

打开异常的源码看了一下

 * Thrown when the Java Virtual Machine attempts to read a class * file and determines that the major and minor version numbers * in the file are not supported.

很明显,是因为是因为去读一个版本不支持的类文件导致的 ,然后我看了一下springboot的jetty是什么版本的,发现这个是最新版本的,估计jetty的最新版本是JDK1.8的吧

后来在官网查看到的结果果然是这样的,那么当然是升级JDK的版本咯 

因为现在的eclipse默认的都只值支持到1.7 所以对于1.8我们还需要自己安装插件  

具体的安装过程,我是从网上搜索的 下面是链接:
http://jingyan.baidu.com/article/d169e186a8532a436611d8a7.html