你的位置:首页 > Java教程

[Java教程]spring 4 xxx 与jackson


这段时间,做一个新的工作流的开发,在开始之初,用的jbpm,后来发现jbpm现在开发有问题,不能引用官方的工作空间,所要工作流跑不起来,于是用了activiti工作流,在配置spring和activiti时,没有问题,但是要新建工作流而调用modeler,打开Modeler页面时,却发现spring与jackson的jar包不兼容,后来仔细一看,原来是版本的问题,spring是最新的版本,而jackson不是,于是就将jackson的所有jar包进行升级,在重新编译运行,然后就没有问题,