你的位置:首页 > Java教程

[Java教程]Solution(项目部署):The server does not support version 3.0 of the J2EE Web module specification


1.错误:

在eclipse中使用run->run on server的时候,选择tomcat6会报错误:The server does not support version 3.0 of the J2EE Web module specification 如下所示:

 

2.原因:

Tomcat 6.0最多支持Servlet 2.5,而现在要import的项目是3.0版本的。

3.解决方法:

在项目根目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.project.facet.core.

1 <??>2 <faceted-project>3  <fixed facet="java"/>4  <fixed facet="jst.web"/>5  <fixed facet="wst.jsdt.web"/>6  <installed facet="java" version="1.6"/>7  <installed facet="jst.web" version="3.0"/>8  <installed facet="wst.jsdt.web" version="1.0"/>9 </faceted-project>

View Code

 

把第7行的3.0换成2.5即可。