你的位置:首页 > Java教程

[Java教程]eclipse新建maven项目(2)


本篇博文是继续之前的博文eclipse新建maven项目(1),那篇博文不在随笔在文章中。
首先按照之前那篇博文进行创建maven项目操作,一系列操作下来之后发现刷新项目后会报错:

别急哈,可以解决。

之后选中项目,鼠标右键:

之后升级maven项目即可看到错误解决了,没有了红叉提示了。
针对于每次升级maven项目后,项目的jdk版本都会变成1.5版本的问题,其实是可以设置的,只需要在pom.

 1  <!-- 源码目录,插件管理等配置 --> 2  <build> 3   <finalName>MavenSpringMVC</finalName> 4   <plugins> 5       <plugin> 6         <groupId>org.apache.maven.plugins</groupId> 7         <artifactId>maven-compiler-plugin</artifactId> 8         <version>3.3</version> 9         <configuration>10           <!-- 指定source和target的版本 -->11           <!-- source 指定用哪个版本的编译器对java源码进行编译 -->12           <source>1.7</source>13           <!-- target 指定生成的class文件将保证和哪个版本的虚拟机进行兼容 -->14           <target>1.7</target>15         </configuration>16       </plugin>17     </plugins>18  </build>

添加的位置是:

这么一来,就不用每次担心更新maven项目后手动调整项目jdk版本的问题了。

转载请注明出处,谢谢。