你的位置:首页 > 操作系统

[操作系统]openssh/ntp/ftp漏洞


这3种漏洞常规加固都要对应操作系统打官方漏洞升级包。既然这么说那下面就是不常规的:

Openssh:

改ssh版本:
whereis ssh //查看ssh目录
cd 到该目录
cp ssh ssh.bak //备份ssh
ssh -V //查看ssh版本
sed -i 's/OpenSSH_6.9p1/OpenSSH_7.2p2/g' ssh //修改版本,前面为当前版本,后面为最新版本
ssh -V //查看核对修改版本
telnet 127.0.0.1 22 //查看版本后回车
cd /usr/sbin/
cp sshd sshd.bak
sed -i 's/OpenSSH_6.9/OpenSSH_7.2/g' sshd //修改版本,前面为当前版本,后面为最新版本
telent 127.0.0.1 22

安全检测工具基于其版本扫描,修改下版本号就行了,web里面的脆弱的javascript库漏洞也可修改js库版本绕过。

NTP:

NTP是网络时间协议(Network Time Protocol),它是用来同步网络中各个计算机的时间的协议。

/* ftp到suse-p目录 */

rpm -Fvh ntp*.rpm
rcntp restart
rpm -qa|grep ntp    //检测ntp安装与否

FTP:

这个可以改下ftpd_banner
vi /etc/vsftpd.conf
ftpd_banner="Authorized users only. All activity may be monitored and reported!"
或者
echo 'ftpd_banner="Authorized users only. All activity may be monitored and reported!"' >> /etc/vsftpd.conf
然后重启服务:
service vsftpd restart
若vsftpd服务是被xinetd托管的话,就重启xinetd服务
service xinetd restart