你的位置:首页 > 操作系统

[操作系统]cocoaPods的安装和使用之详细介绍


一,在Mac OS X上安装Ruby运行环境

步骤1------安装RVM

  $ curl -L https://get.rvm.io | bash -s stable

然后载入RVM环境

$ source ~/.rvm/scripts/rvm

检查一下是否安装正确

$ rvm -v

步骤2------用RVM安装Ruby环境

列出已知的ruby版本

$ rvm list known

可以选择现有的rvm版本来进行安装

$ rvm install 2.3.0

另附:

查询已经安装的ruby

$ rvm list

卸载一个已安装版本 

 $ rvm remove 1.9.2

步骤3 - 设置 Ruby 版本

RVM 装好以后,需要执行下面的命令将指定版本的 Ruby 设置为系统默认版本

$ rvm 2.3.0 --default

这个时候你可以测试是否正确

$ ruby -v

$ gem -v

换成淘宝的,替换方式如下

 $gem source -r https://rubygems.org/
$ gem source -a https://ruby.taobao.org

要想验证是否替换成功了,可以执行:

$ gem sources -l  

正常的输出结果:

CURRENT SOURCES

http://ruby.taobao.org/

到这里就已经把Ruby环境成功的安装到了MacOS X上,接下来就可以进行相应的开发使用了

二、安装CocoaPods

1、安装

$sudo gem install cocoapods

2、检查CocoaPods是否成功安装

$which pod

3.使用search命令搜索类库名

pod search AFNetworking

4.打开xcode,新建一个工程

$cd   xcode工程(注意这里不要拖进整个文件夹!否则会有错误)

$touch Podfile

这时 在根目录下多了一个Pofile文件

page3image32744

5.使用vim编辑podfile

$ vim Podfile

按i进入编辑模式,然后在Podfile文件中输入一下文字:

platform :ios, '7.0'

target "工程名" do

pod 'AFNetworking',

End

然后按esc,然后按:wq保存并退出

这个时候打开Podfile文件就会看到里面添加了刚才在终端输入的语句

6.这时,就可以利用Cocopods下载AFNetworking类库了,这时在终端的当前项目目录下,运行一下命令
$ pod install

这时会看到多了一个.xcworkspace工程,以后打开项目就用这个文件打开,打开之后,就会发现AFNetworking已经成功导入项目了

这里可能的错误

Analyzing dependencies
[!] Could not automatically select an Xcode project. Specify one in your Podfile like so:

project 'path/to/Project.xcodeproj'

错误原因:执行$cd   xcode工程时 工程拖错了!

解决方式:拖入工程,不要拖整个文件夹

 

另外:

如果有一些包不在了,或者Podfile里面的版本改变了,可以使用以下命令更新

$ podupdate