你的位置:首页 > Java教程

[Java教程]应用部署weblogic 报错Unsupported major.minor version 51.0的解决过程


应用部署weblogic 报错Unsupported major.minor version 51.0的解决过程

 

 

1、部署提示错误:Unsupported major.minor version 51.0

1.1 错误现象如下图所示:

1.2 原因分析

类似错误均属于Java版本问题,即JDK版本过低,只要选择相对应的JDK版本编译即可。
48,49,50、51、52是Java编译器内部的版本号:
Unsupported major.minor version 52.0 对应于 JDK1.8(JRE1.8)

Unsupported major.minor version 51.0 对应于 JDK1.7(JRE1.7)

Unsupported major.minor version 50.0 对应于 JDK1.6(JRE1.6)
Unsupported major.minor version 49.0 对应于 JDK1.5(JRE1.5)
Unsupported major.minor version 48.0 对应于 JDK1.4(JRE1.4)

检查发现我ECLIPSE中使用的JDK为1.7,而weblogic使用的JDK为1.6两者不匹配,考虑由于重新安装高版本的weblogic比较麻烦,我选择尝试将eclipse中的JDK修改为1.6版本,解决过程如下:

 

1.3 解决过程

1.3.1将在eclipse中 Window -> Preferences -> Java –Installed JREs,修改为JDK1.6的路径如下图所示

 

1.3.2修改完这个之后控制台报错,Java compiler level does not match the version of the installed Java project facet

原因分析:出现此错误是由于JDK版本和项目所设置的编译等级不一致所致

解决方案:编译等级由1.7修改为1.6

解决过程:

1.3.2.1修改JAVA编译等级

依次选择Window -> Preferences -> Java->Compiler

1.3.2.2修改项目的编译等级

在项目上右击,选择Properties->Java Compiler按下图所示设置

1.3.2.3修改Project Facets的JAVA版本

在项目上右击,选择Properties->Project Facets按下图所示设置

 

1.3.2.4修改Build Path中依赖的Libraries,JRE为1.6

1.3.3用maven打包时,报错maven编译时报错:javac: 无效的目标版本: 1.7

原因分析:由于maven打包时指定了JDK的版本

解决方案:把pom.里的source和target标签里的版本号改成1.6即可,如下图所示

到此问题完美解决,过程很曲折,结果很完美,完成那一刻的心情你懂得。