你的位置:首页 > 操作系统

[操作系统]Xcode7.3更新后插件失效的解决方法


昨天发布的Xcode7.3,用了一天的时间终于装上了(网络不给力),突然发现原来所使用的插件不能用了,当时表情如下:



记得在更新7.2的时候也是这样的,当时重新下载的插件安装成功,但是未免有些麻烦,经过一番研究,发现是原来的插件UUID证书变了,苹果要求必须要加入UUID才能使用,保证插件的稳定性。(UUID:Universally Unique Identifier,是指在一台机器上生成的数字,它保证对在同一时空中的所有机器都是唯一的。按照开放软件基金会(OSF)制定的标准计算,用到了以太网卡地址、纳秒级时间、芯片ID码和许多可能的数字)

解决方案:

1,打开Xcode插件所在的目录:

~/Library/Application Support/Developer/Shared/Xcode/Plug-ins

2,选择已经安装的插件,右击选择“显示包内容”,寻找名为“info.plist”文件,编辑找到“DVTPlugInCompatibilityUUIDs”项,添加一个Item,Item内容为UUID。

3,获取UUID的方法:

打开终端,输入:

defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID

将获取的UUID复制到刚才的Item中,保存。

4,完全退出Xocde(command + Q),重新启动Xocde,此时会提示是否加载插件,选择“Load bundle”

注意:有些时候可能不会出现上面的提示,如果没有显示,执行下面的命令,重启Xcode即可

defaults delete com.apple.dt.Xcode DVTPlugInManagerNonApplePlugIns-Xcode-7.3