你的位置:首页 > Java教程

[Java教程]linux ubuntu下如何安装并且切换java版本(Unsupported major.minor version 52.0)


  最近在做一个dcos(数据中心操作系统)的东西,需要用marathon来做进程管理。遗憾的是0.6版本的marathon在API方面很是缺少,换成了0.15版本之后,运行时提示“Unsupported major.minor version 52.0”,这是提示java版本太低,需要使用java1.8。由于对linux不是很熟,找了一些资料,解决了这个问题。

  我用的是ubuntu系统,系统自带1.6和1.7的java包。这个可以在/usr/lib/jvm/目录下可以看到。接下来进入步骤:

  a.先安装1.8版本的java,可以到官网下载:http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html,可以下载tar.tz格式的,也可以下载.bin格式的。找到想要下载的版本之后可以直接下载,也可以右键复制链接,然后用wget + 网址的方式下载。两种安装方法下面稍作介绍

  b.如果是tar.tz格式的,通过命令 “tar zxvf jdk-8u73-linux-x64.tar.gz  -C /usr/lib/jvm/” ,将其解压到/usr/lib/jvm/下即可,如果是.bin格式的直接运行即可,并且可以跳过变量配置

  c. vi /etc/profile 在文件最末尾添加如下所示内容

    export JAVA_HOME=/usr/lib/jvm/java1.8.0_73

    export JRE_HOME=${JAVA_HOME}/jre

    export CLASSPATH=.:${JAVA_HOME}/lib:${JRE_HOME}/lib

    export PATH={JAVA_HOME}/bin:$PATH

  d.更新默认的jdk

      update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.8.0_73/bin/java 300

    update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/jdk1.8.0_73/bin/javac 300

    切换版本

      update-alternatives --config java

    在命令行显示的内容中选择需要的jdk版本的序号,2回车

    update-alternatives --config javac javac选择同上

  e.最后用java -version 和javac -version来检查一下版本,是不是已经更换了呢。