你的位置:首页 > 操作系统

[操作系统]Andrord问题小结


问题描述:
Gradle version 2.10 is required. Current version is 2.8.
Gradle版本由2.8升为2.10后,发现所有依赖play-services的module都无法构建了,提示如下错误:
java.io.FileNotFoundException:...\build\intermediates\exploded-aar\com.google.android.gms\play-services\8.4.0\jars\classes.jar (系统找不到指定的路径。)

问题原因:

这是gradle工具版本
gradle:2.0.0-alpha5的bug,gradle:2.0.0-alpha6已解决
2.0.0-alpha6 (2016/1/15)Instant Run Fix alpha5 reported issues :  - cannot build when importing play-services.

解决方法:
 dependencies {    classpath 'com.android.tools.build:gradle:2.0.0-alpha6'  }