你的位置:首页 > Java教程

[Java教程]node.js之看懂package.json依赖库版本控制


金天:学习一个新东西,就要持有拥抱的心态,如果固守在自己先前的概念体系,就会有举步维艰的感觉。
node.js依赖库的版本控制
金天微信:15998603918 欢迎找我聊聊天。

 

一般node.js项目会依赖大量第三方module, 那么如何控制module的版本呢?

答案通过package.json。

"dependencies": {
//精确匹配 "async": "1.2.1",
//近似 相当于0.7.* "pdfkit": "^0.7.0",
//兼容匹配 大版本一致 相当于0.*.* "sharp": "~0.11.4" }

更多参考下面链接:

 

http://tianmaying.com/snippet/8ab3eda84d5c277c014d6672bffe0055

http://www.u396.com/semver-range.html

http://www.cnblogs.com/ganiks/p/npm-install-package-version.html

https://github.com/npm/node-semver