你的位置:首页 > Java教程

[Java教程]Tomcat 运行第一个servlet时发生Unsupported major.minor version 52.0错误


使用Tomcat运行第一个servlet程序是发生如图错误:

image

查找资料后发现是由于使用高版本的jdk编译的项目运行在低版本的jre上,决解办法是编译的jdk和运行的jre版本一致。

查看Tomcat使用的jre确实和编译时使用的不一致(当初安装了两个jdk);

image

image

后面把Tomcat的jre改为1.8就可正常运行:

image