你的位置:首页 > 操作系统

[操作系统]关于centos6.7使用VSCode的问题解决(未解决)


只解决了VSCode运行时提示/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by code)

并没有解决/lib64/libc.so.6: version `GLIBC_2.14' not found (required by code)

说一下/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found是怎么解决的吧

登陆Linux Packages Search - pkgs.org 查找libstdc++.so.6发现libstdc++-4.4.7-16.el6.x86_64.rpm

    libstdc++ = 4.4.7-16.el6
    libstdc++ = 4.4.4-15.el6
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3.1)(64bit)
    libstdc++.so.6(CXXABI_1.3.2)(64bit)
    libstdc++.so.6(CXXABI_1.3.3)(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.10)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.12)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.13)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.1)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.2)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.3)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.4)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.5)(64bit)
    libstdc++.so.6(GLIBCXX_3.4)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.6)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.7)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.8)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
    libstdc++(x86-64) = 4.4.7-16.el6
 
不带GLIBCXX_3.4.14和GLIBCXX_3.4.15

但是在他的下下面 chrome-deps-stable-3.11-1.i386.rpm里发现

  • chrome-deps-stable = 3.11-1
  • chrome-deps-stable(x86-32) = 3.11-1
  • libgnome-keyring.so.0
  • libstdc++.so.6
  • libstdc++.so.6(CXXABI_1.3)
  • libstdc++.so.6(CXXABI_1.3.1)
  • libstdc++.so.6(CXXABI_1.3.2)
  • libstdc++.so.6(CXXABI_1.3.3)
  • libstdc++.so.6(CXXABI_1.3.4)
  • libstdc++.so.6(CXXABI_1.3.5)
  • libstdc++.so.6(CXXABI_1.3.6)
  • libstdc++.so.6(CXXABI_1.3.7)
  • libstdc++.so.6(CXXABI_TM_1)
  • libstdc++.so.6(GLIBCXX_3.4)
  • libstdc++.so.6(GLIBCXX_3.4.1)
  • libstdc++.so.6(GLIBCXX_3.4.10)
  • libstdc++.so.6(GLIBCXX_3.4.11)
  • libstdc++.so.6(GLIBCXX_3.4.12)
  • libstdc++.so.6(GLIBCXX_3.4.13)
  • libstdc++.so.6(GLIBCXX_3.4.14)
  • libstdc++.so.6(GLIBCXX_3.4.15)
  • libstdc++.so.6(GLIBCXX_3.4.16)
  • libstdc++.so.6(GLIBCXX_3.4.17)
  • libstdc++.so.6(GLIBCXX_3.4.18)
  • libstdc++.so.6(GLIBCXX_3.4.19)
  • libstdc++.so.6(GLIBCXX_3.4.2)
  • libstdc++.so.6(GLIBCXX_3.4.3)
  • libstdc++.so.6(GLIBCXX_3.4.4)
  • libstdc++.so.6(GLIBCXX_3.4.5)
  • libstdc++.so.6(GLIBCXX_3.4.6)
  • libstdc++.so.6(GLIBCXX_3.4.7)
  • libstdc++.so.6(GLIBCXX_3.4.8)
  • libstdc++.so.6(GLIBCXX_3.4.9)
  • /opt/google/chrome/lib/link-to-libgnome-keyring.so.0

这个包里有GLIBCXX_3.4.14下载64位版本 用归档管理器打开chrome-deps-stable-3.11-1.x86_64.rpm把/./opt/google/chrome/lib/libstdc++.so.6解压出来

使用root身份将其移动到/usr/lib64/下 记得备份

 

至于/lib64/libc.so.6: version `GLIBC_2.14' not found 还没有解决 希望有大神可以指点一二。