你的位置:首页 > 操作系统

[操作系统]Android Studio导入github下载的工程


        现在从github上面现在的项目大部分都是Android Studio工程,那么问题来了,从github上面down一个工程下来,怎么导入android studio呢?

对刚从eclipse转Android Studio的童鞋来说,可能会遇到各种问题。下面方法可以简单快速的将github上的项目导入android studio并运行。
        首先提一下,Android Studio是基于Gradle来构建项目的,这个与eclipse不同,所以想要熟练掌握Android Studio的用法,最好还是先熟悉Gradle。
这里只是介绍Android Studio如何导入工程,关于Gradle,可以自行百度。
        下面介绍Android Studio如何导入project。
        一、安装Android Sudio并新建project
        安装Android Studio后,创建Project,会自动下载Gradle。工程目录结构如下:
        
 
        二、将github下载的project中的gradle版本替换为本地的版本
        如果直接将project导入进Android Studio的话,会去下载工程相应版本的gradle,此过程非常慢,有时候还会出现各种错误。所以直接使用本地已有的gradle。
替换方法很简单,只需要将本地创建的工程中的相应文件夹复制到从github下载的project替换之。
        
 
        三、导入project到Android Studio
        File-->new-->import project,会弹出下面对话框,选中github下载下来的project后点击OK即可。我这里使用volley的demo作为示例。
        
        导入后如下图:
        
 
        四、替换Module的target SDK
        工程导入后有可能还会编译报错,原因有可能是app Module中gradle配置中target SDK高于你本地SDK的版本。解决办法很简单,打开app/build.gradle文件
apply plugin: 'com.android.application'android {  compileSdkVersion 22  buildToolsVersion "22.0.1"  defaultConfig {    applicationId "com.timliu.volleyactivity"    minSdkVersion 21    targetSdkVersion 22    versionCode 1    versionName "1.0"  }  buildTypes {    release {      minifyEnabled false      proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'    }  }}dependencies {  compile project(':volleysrc')  compile fileTree(dir: 'libs', include: ['*.jar'])  compile 'com.android.support:appcompat-v7:22.2.0'}

  




        因为我本地的sdk版本最高为21,而此Module的targetSdkVersion为22,所以为编译出错。我们只要将文件稍微改动一下即可,改后的文件如下:

apply plugin: 'com.android.application'android {  compileSdkVersion 21  buildToolsVersion "20.0.0"  //这里也需修改  defaultConfig {    applicationId "com.timliu.volleyactivity"    minSdkVersion 21    targetSdkVersion 21    versionCode 1    versionName "1.0"  }  buildTypes {    release {      minifyEnabled false      proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'    }  }}dependencies {  compile project(':volleysrc')  compile fileTree(dir: 'libs', include: ['*.jar'])  compile 'com.android.support:appcompat-v7:21.0.2' //这里也需修改}

  




        因为app Module依赖volleysrc Library,所以volleysrc/build.gradle文件也做同样的修改。

 
        五、重新编译
       点击按钮对项目重新进行编译。此时编译就不会出错了。编译后,你会发现app目录的图标右下角多了个手机的图标,目录结构如下:
        
   
        此时就可以正常运行github下载下来的项目了。