你的位置:首页 > Java教程

[Java教程][译]WordPress 4.3 将会用node.js重写


一个核心的wordpress开发者Ryan Boren表示,wordpress4.3 cms系统将会有一个重大的变革,那就是用node.js重写,同时完全兼容之前的版本。

WordPress 和 Node.js

开发者以及项目本身已经关注node.js很久了,当然,这早就不是什么秘密了,node.js允许你用javascript写服务端代码。

我们首次使用node.js是在3.7版本中,同时也把Grunt工具加入了我们的开发周期中。自那以后,越来越多的核心版本开始使用javascript,NB的是,这门语言也被认为是2015年发展最快的语言,没有之一。

需要说明的是,在wordpress4.3版本中完全抛弃PHP也不现实,但是开发者计划在基础模块、核心模块中使用它,这其中包括WP_Query , WP_Error and WP_Object_Cache。

系统要求和后向兼容

正如之前提到,开发者没有计划在最近的版本中完全抛弃PHP,同时也会详细的介绍新版的用法,来帮助大家后向兼容并完全的适配现有的主题和插件。

一个叫node2php的模块来确保大部分的兼容性工作。它基本的工作原理是,首先会分析编译后的php二进制代码然后再转译成JavaScript,目前这个模块正在测试阶段。

另外一个不得不提的兼容性问题就是系统兼容性,新版的wordpress如何适配当前的主机环境。毕竟,不是每个公司都能快速并且提供可靠的node.js运行环境,尤其是当下的环境已经很便宜了。

幸运的是,非常多的供应商同wordpress的核心开发组紧密的工作在一起,新版本当然可以承诺完全的兼容。官方计划在2015年10月份发布WordPress 4.3版本。