你的位置:首页 > 操作系统

[操作系统]错误提示,解决方案java.lang.UnsatisfiedLinkError: Couldnt load easemobservice from loader dalvik.system.PathClassLoad


 

解决方案:

     在libs下面创建一个armeabi-v7a文件夹

     把armeabi *.so的文件复制一份

     放在armeabi-v7a运行测试通过

 

关于 armeabi和armeabi-v7a 区别如下:

 armeabi和armeabi-v7a是表示cpu的类型,我们知道一般的手机或平板都是用arm的cpu(mips的就悲催的被忽视了),不同的cpu的特性不一样,armeabi就是针对普通的或旧的arm cpu,armeabi-v7a是针对有浮点运算或高级扩展功能的arm cpu。

在android.mk里可配置以下宏:

TARGET_CPU_API := armeabi

APP_ABI := armeabi

现在还有x86的了,其实armeabi 、armeabi-v7a 和x86是编译 NDK 库时,可以使用三种支持的应用二进制接口(ABI):

  1. ‘armeabi’ – 默认选项,将创建以基于 ARM* v5TE 的设备为目标的库。 具有这种目标的浮点运算使用软件浮点运算。 使用此 ABI 创建的二进制代码将可以在所有 ARM* 设备上运行。
  2. ‘armeabi-v7a’ – 创建支持基于 ARM* v7 的设备的库,并将使用硬件 FPU 指令。
  3. ‘x86’ – 生成的二进制代码可支持包含基于硬件的浮点运算的 IA-32 指令集。

 

希望能够帮助你。

丶贰九

转发,请注明出处:[url]http://www.cnblogs.com/kevin-chen/p/kevin-chen.html[/url]